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Desktop Troubleshooting 
and Configuration Guide

 

Product and Versions  Contract Version 6.8.1 
Document Dated  August, 2011, Updated November, 2013 

 

Overview of Known Issues 
Prodagio Contract is a browser based application. This Guide details the known issues and 
troubleshooting recommendations, as well as the desktop hardware and software requirements 
to optimize Prodagio Contact 6.8.1 performance. 

This document is intended for use by those IT members responsible for desktop management 
and third-party software configuration. 

Troubleshooting issues are grouped as follows: 

 UCF and Java related issues 

 Java only issues 

 Browser issues 

 Drag and Drop issues 

 Add-On issues 

 Workflow Instances issues 

An Appendix details recommended browser hardware, software and operating environments 
and provides more details about the role of UCF and how it can be pre-installed. 

The Table of Contents on the next page lists more details of this Guide’s various sections. 

Note: the screen captures used in this document are from Internet Explorer 9 and Windows 7. 
The appearance of your screen captures many differ if using other browsers and browser 
versions and operating system versions. 

If at all possible, troubleshooting issues in the order presented in this document. 



Page 2 Desktop Troubleshooting and Configuration Guide — Prodagio Contract 

Table of Contents 
 

Overview of Known Issues ........................................................................................................................ 1 
UCF and Java Issues Defined .................................................................................................................. 3 

Troubleshooting UCF and Java Issues ................................................................................................. 3 
End All Running Java Processes on Windows 7 Professional ......................................................... 3 
Clear the Java Cache on Windows 7 Professional ........................................................................... 4 
Delete the UCF Folder and Its Contents ........................................................................................... 4 
Windows Vista Settings and UCF ..................................................................................................... 5 

Java Issues Defined .................................................................................................................................. 5 
Removing the 'Your Browser Does Not Meet Requirements' Message ............................................... 5 

Uninstall Current Java Version .......................................................................................................... 5 
Install 32-Bit Java .............................................................................................................................. 6 

Browser Issues Defined ............................................................................................................................ 6 
Checking for Newer Versions of Stored Pages .................................................................................... 6 

Internet Explorer 9 and Internet Explorer 10 ..................................................................................... 6 
Clearing the Browser Cache ................................................................................................................. 7 

Internet Explorer 8 ............................................................................................................................. 7 
Internet Explorer 9 and Internet Explorer 10 ..................................................................................... 8 

Adding the Prodagio URL to the ‘Trusted Sites’ Security Registry ....................................................... 8 
Allowing Pop-Ups in Prodagio ............................................................................................................ 10 

Add-On Issue Defined ............................................................................................................................. 10 
Uninstalling Add-On Toolbars ............................................................................................................. 11 

Drag and Drop Plug-In Issue Defined ..................................................................................................... 11 
Installing the Drag and Drop Plug-In on 32-Bit Windows Systems Running the Internet Explorer 

Browser ............................................................................................................................................... 11 
Installing the Drag and Drop Plug-In on 64-Bit Windows Systems Running the Internet Explorer 

Browser ............................................................................................................................................... 12 
Verify the Accurate Installation of the Drag and Drop Plug-In ............................................................ 12 
Configure Java to Enable Drag and Drop ........................................................................................... 12 
Conditions Not Supported by the Drag and Drop Plug-In ................................................................... 13 

Workflow Instances Issues Defined ........................................................................................................ 13 
Installing the Arial Unicode MS Font ................................................................................................... 14 

Appendix ................................................................................................................................................. 15 
Recommended Browser Hardware, Software and Environments ...................................................... 15 

Browser Hardware Requirements ................................................................................................... 15 
Browser Software Requirements .................................................................................................... 15 
Complete Browser Reset ................................................................................................................ 17 

The Role of the UCF Plug-In ............................................................................................................... 17 
Administrator Pre-Installation of UCF ............................................................................................. 18 
For Example .................................................................................................................................... 18 

 



Desktop Troubleshooting and Configuration Guide — Prodagio Contract  Page 3 

Troubleshooting Desktop Configurations 
 

UCF and Java Issues Defined 
Issue: the web browser hangs or displays a blank page when importing, viewing , checking out 
and checking in or when saving a local copy of documents. 

 Resolution:  

End running Java Processes  

Clear the Java cache 

Delete the UCF folder and its contents 

Windows Vista settings and UCF 

 

Troubleshooting UCF and Java Issues 
Perform these three procedures at one time. 

End All Running Java Processes on Windows 7 Professional 

1. Log out of Prodagio. 

2. Open your browser. 

3. To end any running Java processes: 

a. Click Ctrl + Alt + Delete to display the Window Security window. 

b. Click  Start Task Manager. Windows Task Manager displays. 

 

c. Click the Processes tab. 
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d. Select the Image Name javaw.exe and/or java.exe and click the End Process 
button. 
The Windows Task Manager window displays. 

e. Click the End Process button. 

4. Close the Windows Task Manager window. 

 

Clear the Java Cache on Windows 7 Professional 

1. Log out of Prodagio. 

2. Open the Windows Control Panel. 

3. Click Programs. 

4. Double-click  Java. The Java Control Panel displays. 

5. In the Temporary Internet Files area, click the Settings button. 

6. In the Temporary File Settings window, click the Delete Files… button. 

7. In the Delete Temporary Files window, check  Applications and Applets and check  
Trace and Log Files. 

8. Click  to close the Delete Temporary Files window. 

9. Click  to close the Temporary File Settings window. 

10. Click  to close the Java Control Panel window. 

11. Close the Control Panel window. 

 

Delete the UCF Folder and Its Contents 

1. Log out of Prodagio. 

2. On Vista and Windows 7, go to: C:\users\<user name>\Documentum\ucf 

3. Right-click ucf, select Delete, then click  in the Delete Folder window. The ucf 
folder is removed. 

4. If the ucf folder cannot be deleted, perform Clear the Java Cache (above) and then delete 
the ucf folder. 
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Windows Vista Settings and UCF 

Cookies must be enabled in the browser. 

In order for UCF content transfer related operations such as import, export, view, check out, 
check in and preferences to function properly under the Windows Vista operating system, you 
must choose one of the following: 

 turn off User Account Control (UAC) for each user or in the browser. 

 in the application, set the UCF client configuration registry.mode value to File instead of 
Windows. 

 

Java Issues Defined 
Issue: Your browser does not meet requirements message displays, a blank screen displays or the 
UCF Session Wait Timeout  error displays. 

Resolution:  

Install the recommended Java version 

Disable automatic updating of Java 

Perform all troubleshooting in UCF and Java Issues Defined. 

 

Removing the 'Your Browser Does Not Meet Requirements' Message 
Automatic updates to the recommended Sun JRE versions sometimes corrupt the functioning 
UCF installation. 

JRE 6 Updates 22 through Update 24 are not compatible with the UCF plug-in and will cause 
file transfers to not function (for example “Save a Local Copy” may not function). 

To remove this message, install the 32-bit version of Java version 6u25 or higher to replace the 
current 32-bit or 64-bit version.  

As of late November, 2013, the latest compatible Java version is: Java 6 Update 31 (build 
1.6.0_31-b05). 

Uninstall Current Java Version 

1. Exit all open Internet Explorer browsers. 

2. Click Start > Settings > Control Panel. 

3. Click Add or Remove Programs. 

4. Click a listed Java version. 
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5. Click the Remove button. 

6. Repeat for each Java version 

7. Close the Add or Remove Programs window. 

Install 32-Bit Java 

1. Exit all open Internet Explorer browsers. 

2. Install the 32-bit version of JRE 6 over your system's existing Java 64-bit version. 

3. Open the java.com website, find and install this file: jre-6u25-windows-i586-s.exe 
(or higher) 

To Test: open and launch the Internet Explorer browser again. The Your browser does not meet 

requirements message no longer displays. 

Then, in the Java Control Panel, disable the automatic updating of the currently installed Java 
version. See Error! Reference source not found.. 

 

Browser Issues Defined 
Issue: Web browser does not completely refresh a page, display pop-ups or icons do not display 
correctly. 

Resolution:  

Check for newer versions of stored pages 

Clear the browser cache in your Internet Explorer version 

Add the Prodagio URL to the ‘Trusted Sites’ Security Registry 

Allow pop-ups. 

 

Checking for Newer Versions of Stored Pages 
Most browsers are set to store copies of web pages for faster viewing the next time that page is 
called. This ‘page storing’ may prohibit the Prodagio user from viewing the very latest changing 
information. 

Internet Explorer 9 and Internet Explorer 10 

1. At each desktop, open Internet Explorer 9 or Internet Explorer 10. 

2. Select Tools > Internet Options. 
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3. The Internet Options window displays. 

4. On the General tab, in Browsing History, click Settings.... The Temporary Internet Files and 
History Settings window displays. 

5. Select  Every time I visit the webpage. 

6. Click . The Temporary Internet Files and History Settings window closes. 

7. Click . The Internet Options window closes. The very latest pages now will 
display. 

 

Clearing the Browser Cache 
Each version of Internet Explorer has a slightly different procedure for clearing the browser 
cache. 

Note: Deleting everything can free hard disk space, solve problems with your web browser, and 
provide some additional privacy, but it might inconvenience you by removing information you 
might need on the Internet. For example, you will have to retype passwords that were 
previously stored on your computer. 

Internet Explorer 8 

1. At each desktop, open Internet Explorer 8. 

2. Click Tools, then click Internet Options. The Internet Options window displays its General 
tab. 
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3. In the Browsing history area, click . The Delete Browsing History window 
displays. 

4. Check  Preserve Favorites website data, Temporary Internet files, Cookies and History to 
identify what to delete. 

5. Click . 

6. On the Internet Options window, click . 

Internet Explorer 9 and Internet Explorer 10 

8. At each desktop, open Internet Explorer 9 or Internet Explorer 10. 

9. Click the F12 key. The Debugger window displays along the bottom of the screen. 

10. Click Ctrl-R.  The Clear Browser Cache window displays. 

 

11. Click . Wait until the Please Wait window no longer displays. 

12. Close the debugger window. 

13. Close IE9 or IE10. The IE9 or IE10 cache is now cleared. 

 

Adding the Prodagio URL to the ‘Trusted Sites’ Security Registry 
1. Select Tools > Internet Options in the Internet Explorer browser. 
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2. The Internet Options window displays. 

3. Click the Security tab. 

 

4. Click the Trusted sites icon. 

5. Click the Sites button. The Trusted sites window displays. 

 

All trusted Websites are listed in the Websites pane. 
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6. In the Add this website to the zone field, enter the current Prodagio URL not in the 
Websites pane. 

7. Clear  Require server verification (https:) for all sites in this zone option. 

8. Click the Add button. If needed, repeat for each trusted website. 

9. Click the Close button. 

10. Click  to close Internet Options windows. 

11. Close, then re-launch the Internet Explorer browser. 

 

Allowing Pop-Ups in Prodagio 
Prodagio Contract requires pop-ups to display. By default, Internet Explorer displays pop-ups 
that often display after clicking a link or button. Pop-up blockers block pop-ups that are 
displayed automatically (without clicking a link or button). To enable pop-ups for Prodagio 
Contract,  follow these steps: 

1. Open Internet Explorer IE9 or IE10. 

2. Click Internet Options. 

3. Click the Privacy tab. 

4. In the Pop-up Blocker area, clear  Turn on Pop-up Blocker. 

5. Click the Apply button on the Privacy Tab. 

6. Click  on the Privacy Tab. 

7. Repeat the above steps for each workstation running Prodagio Contract. 

 

Add-On Issue Defined 
Issue: after properly configuring all settings for the UCF, Java and in the browser, the browser 
sometimes behaves in an unexpected manner. 

Resolution: 

Uninstall all installed add-ons, such as Google and Yahoo! toolbars. 
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Uninstalling Add-On Toolbars 
Some installed toolbars such as Google and Yahoo! may interfere with the UCF plug-in or with 
URL processing. 

To uninstall add-on toolbars: 

1. Click Settings > Control Panel > Add or Remove Programs. 

2. In the list of Programs, identify the toolbar to uninstall and click the Remove button. 

3. Follow the uninstall instructions for that toolbar. 

 

Drag and Drop Plug-In Issue Defined 
Issue: Drag and Drop file importing from the desktop to Prodagio or export of Prodagio files to 
the desktop or moving files within Prodagio does not function properly.  

Note: On Prodagio Contract 6.8.1 and greater systems using the Windows operating system and 
the Internet Explorer browser, Drag and Drop file importing from the desktop to Prodagio or 
export of Prodagio files to the desktop or moving files within Prodagio is disabled because 
Prodagio Contract 6.8.1 has standardized on the HTTP file transfer method and does not use the 
UCF file transfer method, standard with previous versions. 

If your system uses a previous version, it most likely uses the UCF file transfer method and if 
your Drag and Drop is not functioning, this section applies. 

Certain conditions are not supported by the Drag and Drop plug-in. These conditions are listed 
at the end of this section. 

Resolution: 

Install the ActiveX plug-in, either the 32-bit or 64-bit versions. Test for proper operation. 

Installing the Drag and Drop Plug-In on 32-Bit Windows Systems Running the Internet 
Explorer Browser 
This installation is a one-time download and after installation, Drag and Drop must be enabled: 

1. Locate the Documentum plug-in cab file at webapps\webtop\wdk\native\WdkPluginCab.CAB. 
and push it to the ProdagioContract\wdk\native\WdkPluginCab.Cab location. Ensure that the 
user has the required permission to access this folder. 

2. Extract all dll files (including wdkplugin.dll) from the cab file. 

3. Place the XceedZip.dll and ExJNIAPI.dll files in the %windir%\system32 directory. 

4. Register each dll with the regsvr32 utility. Run the following command to register each 
dll: 
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regsvr32 dll name 
For example, regsvr32 wdkplugin.dll, regsvr32 XceedZip.dll  

5. Access the Webtop application and navigate to Tools > Preferences. Ensure that the Drag 
and Drop plug-in check box is enabled (default setting). 

Installing the Drag and Drop Plug-In on 64-Bit Windows Systems Running the Internet 
Explorer Browser 
This installation is a one-time download and after installation, Drag and Drop must be enabled: 

1. Locate the Documentum plug-in cab file at webapps\webtop\wdk\native\WdkPluginCab.CAB. 
and push it to the ProdagioContract\wdk\native\WdkPluginCabx64.Cab location Ensure that 
the user has the required permission to access this folder. 

2. Extract all dll files (including Wdkpluginx64.dll) from the cab file. 

3. Place the XceedZip.dll and ExJNIAPI.dll files in the %windir%\SysWPW64 directory. 

4. Register each dll with the regsvr32 utility. Run the following command to register each 
dll: 
regsvr32 dll name 
For example, regsvr32 WdkPluginx64.dll, regsvr32 XceedZip.dll  

5. Access the Webtop application and navigate to Tools > Preferences. Ensure that the Drag 
and Drop plug-in check box is enabled. 

The Drag and Drop plug-in will be enabled on users PCs. The DMDragDrop class can be 
viewed under C:\WINNT\Downloaded Program Files. 

Note: The 32-bit WDK plug-in can be registered on the 64-bit machine as well. It would 
work exactly the same as the 64-bit plug-in. 

Verify the Accurate Installation of the Drag and Drop Plug-In 
After installation and enabling, verify the accurate operation of the Drag and Drop plug-in: 

1. Navigate to the Windows or WinNT directory of the Application Server and/or the 
client machine. 

2. Verify if the Downloaded Program Files folder contains the DMDragDrop Class file. If the file 
is not present, it indicates that the plug-in has not been installed correctly. 

Configure Java to Enable Drag and Drop 
To enable Drag and Drop, a Java setting must be configured: 

1. Log out of Prodagio. 

2. Open the Windows Control Panel. 
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3. Double-click  Java. The Java Control Panel displays. 

a. On the General tab, click Network Settings…. 

b. Select the Direct connection radio button. 

c. Click  to close the Network Settings window. 

d. Click  to close the Java Control Panel window. 

e. Close the Control Panel window. 

4. Clear the Java Cache (see Clear the Java Cache). 

5. Delete the UCF folder (see Delete the UCF Folder and its Contents). 

6. Log into Prodagio. Drag and Drop is enabled. 

 

Conditions Not Supported by the Drag and Drop Plug-In 
The properly-installed Drag and Drop plug-in does not support these conditions: 

 Accessibility mode is turned on the user 
 A window is created by launching the browser again and a new WDK application 

session appears 
Note: You can Drag and Drop with a WKD window that is created with the WDK New 
Window menu item. 

 XML documents are dragged to or from the desktop 
 Virtual documents are dragged to or from the desktop 
 OLE compound documents need to be dragged or dropped 

Java 6 or higher is recommended in the Documentum Release Notes because issues related 
to Drag and Drop have been known to exist with previous versions of Java.  

 

Workflow Instances Issues Defined 
Issue: after clicking View Instance, a Workflow Manager message says “there is no Unicode font 
found on the system” and the workflow instance never displays 
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Resolution: install the Arial Unicode MS font 

The Arial Unicode MS font is required to properly display workflow instances when launching 
Java and Web Workflow Manager. This font is a found in the standard Microsoft Office font 
package. 

Installing the Arial Unicode MS Font 
To install the Arial Unicode MS font (Microsoft Office 2007, Windows 7): 

1. Click Control Panel > Programs > Programs and Features 

2. Highlight Microsoft Office 2007,  right-click and select Change. 

3. Check Add or Remove Features and click the Continue button. 

4. Click to expand Office Shared Features. 

5. Click to expand International Support. 

6. Click the icon next to Universal Font, then click Run from My Computer. 

7. Click Update to complete the installation of the Universal Font (Arial Unicode MS). 
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Appendix 

Recommended Browser Hardware, Software and Environments 
The following tables define which combinations of operating system, browser and JRE are 
supported by Prodagio. 

 

Browser Hardware Requirements 

For Prodagio client applications, a client machine capable of running the supported software 
configurations listed in the Browser environment table is needed, plus whatever disk space, 
RAM or CPU requirements that may be specified by third-party products such as Microsoft 
Office. Prodagio client applications install a JRE based applet on the client machine. This 
requires approximately 100 MB of free hard disk space. Additionally, sufficient free disk space 
is needed to handle checked-out and cached documents. 

 

Browser Software Requirements 

The tables in this section provides information on supported software environments and reflect 
the latest versions of third-party products, upon which the Prodagio product depends that are 
supported at the time of this release. Prodagio recommends upgrading third-party products to 
the version listed for this release. If third-party products cannot be upgraded to the version 
listed for this release, Prodagio continues to support all third-party product versions supported 
with the following caveats: 

 the third-party product is not of the same or earlier version than those versions listed in the 
table below 

 the third-party product version is still supported by the third-party vendor 

 the third-party product version is forward compatible with the version supported in this 
release. 
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Third-party product versions NOT supported in this release 

Product Category Third Party Products Version 

Operating System Windows Windows 2000 SP2 Update Rollup 1 

Browser 

Mozilla 1.7.13 

Netscape 7.2 

Safari 1.3.2 

JRE (Client) 

Sun JRE 1.4.2_13 

Microsoft JVM 5.0.0.3810 

Apple Java 1.3.1 Release 2 

 

The user interface for Prodagio clients runs in a browser environment. The browser 
environment consists of a specific combination of operating system, browser, and JRE. The 
following browser environment table for Prodagio lists the supported browser environments. 
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Complete Browser Reset 

If all suggested browser troubleshooting steps listed in this document have been completed and 
do not resolve all unexpected browser behavior, Microsoft Internet Explorer provides a Reset 
feature. Only use this feature if your browser is in an unstable state. Resetting affects all 
applications accessed through the browser because it deletes all temporary files, disables 
browser add-ons and resets any changed settings. 

1. In IE 9, click > Internet Options > Advanced Tab > Reset Internet Explorer settings 

2. Click . 

The Role of the UCF Plug-In 
The standard file transfer method for Prodagio Contract is the HTTP file transfer protocol, 
which is a internet standard. Use of HTTP file transfer disables drag and drop. 

However, in some Prodagio Contract installations, content transfer is managed instead by the 
UCF plug-in. UCF (“Unified Content Facilities”) is a lightweight applet responsible for 
transferring content between the content server, application server and the desktop machine 
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during operations such as view check-in, checkout, import, etc. UCF is a Java-based client 
application that is installed at run-time. 

The Java plug-in can be installed in one of the following ways: 

1. By the user when Prodagio first requests use of the plug-in. 

Note: The user must answer “Yes” to all prompts by the browser for trusted site access and 
plug-in installation. 

2. By a pre-installation script run by the IT group. See Administrator Pre-Installation of 
UCF. 

 

Administrator Pre-Installation of UCF 

Prodagio Contract contains a UCF installer tool that enables administrators to pre-install UCF. 
You may wish to use this in locked environments or in order to provide a better user 
experience, avoiding the downloading and installation of UCF when the user accesses Prodagio 
Contract for the first time. 

To pre-install UCF, invoke the following command from command line.  

java -cp "\\some network path\ucfinit.jar" com.documentum.ucf.client.install.TestInstall 
  server_host relative_path_to_ucf.installer.config.xml 

where:  

server_host is the URL to the Prodagio application server host  
relative_path_to_ucf.installer.config.xml is the path relative to the Prodagio application root 
directory  
 
ucfinit.jar file is located in the deployed Prodagio application 
 …\ProdagioContract67\wdk\system\ucfinit.jar 

For Example 

java -cp "\\pro65ws1\d$\Program Files\Apache Software Foundation\Tomcat 
6.0\webapps\ProdagioContract67\wdk\system\ucfinit.jar" com.documentum.ucf.client.install.TestInstall 
"http://pro65ws1:8080/ProdagioContract67" "/wdk/contentXfer/ucf.installer.config.xml" 

Successful installation returns the message Installation successful. Failure returns an appropriate 
message with the corresponding stack trace.  

Please note the following requirements and limitations:  

 The installation command should be executed physically for the OS user on the user's 
machine.  
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 The tool won't work if the application server host or the ucf.installer.config.xml file is not 
accessible via a simple URL connection. For example, it may not work for SSO or proxy 
environments.  

 The tool is unsupported and is provided for administration convenience. 

 


